38 lines
1.2 KiB
Nix
38 lines
1.2 KiB
Nix
# @begin:license
|
|
#
|
|
# Copyright (c) 2015-2021, Ben Niemann <pink@odahoda.de>
|
|
#
|
|
# This program is free software; you can redistribute it and/or modify
|
|
# it under the terms of the GNU General Public License as published by
|
|
# the Free Software Foundation; either version 2 of the License, or
|
|
# (at your option) any later version.
|
|
#
|
|
# This program is distributed in the hope that it will be useful,
|
|
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
# GNU General Public License for more details.
|
|
#
|
|
# You should have received a copy of the GNU General Public License along
|
|
# with this program; if not, write to the Free Software Foundation, Inc.,
|
|
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
|
#
|
|
# @end:license
|
|
|
|
let
|
|
nixpkgs = import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/d14d83a3691121642be1b0579cf3408a83c558d7.tar.gz") {};
|
|
noisicaa = import ./noisicaa.nix {
|
|
withTests = true;
|
|
};
|
|
in nixpkgs.mkShell {
|
|
packages = [
|
|
nixpkgs.meterbridge
|
|
];
|
|
inputsFrom = [ noisicaa ];
|
|
|
|
inherit (noisicaa) QT_QPA_PLATFORM_PLUGIN_PATH QT_PLUGIN_PATH QML2_IMPORT_PATH QT5_LIBDIR PYTHONPATH;
|
|
|
|
# sometimes(?) fails to use new .qml code...
|
|
QML_DISABLE_DISK_CACHE = 1;
|
|
}
|
|
|