An open source DAW for GNU/Linux, inspired by modular synths. http://noisicaa.odahoda.de/
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
Ben Niemann 13bef24fad Minor cleanup. 3 years ago
3rdparty MidiCCtoCV: add MIDI learn mode. 3 years ago
bin Fix name collision when there's more than one Faust processor. 3 years ago
cmake Use cmake for building. Started rewriting the audio core in C++. 5 years ago
data Show icons in insert node dialog. 3 years ago
docs/dev Initial dev docs for vmtests. 4 years ago
noisicaa Minor cleanup. 3 years ago
noisidev Fix tests. 3 years ago
playground Custom UI for mixer nodes and an Instrument node to bring back sample playback. 4 years ago
testdata Update licenses to 2019. 4 years ago
testlogs Use cmake for building. Started rewriting the audio core in C++. 5 years ago
website Blog post: Development update (April 6) 3 years ago
.dir-locals.el Add pyvenv-workon to .dir-locals.el 3 years ago
.gitignore Initial website sources. 4 years ago
.projectile Add a .projectile file. 3 years ago
CMakeLists.txt Generate a JSON dump of the faust meta data. Autogenerate the NodeDescription from it. 3 years ago
COPYING Initial commit to git (from latest version in svn). 7 years ago
README.md More improvements to vmtests and listdeps. 4 years ago
listdeps Update mypy and pylint to the latest versions. 3 years ago
setup.py Update licenses to 2019. 4 years ago

README.md

noisicaä

Important note: This is project is in pre-APLHA state, do not expect it to be usable in any form or shape.

  • It has bugs.
  • It does not do a lot of useful things.
  • There is no documentation.
  • And most importantly: the save format is not finalized and will change in incompatible ways, i.e. you will not be able to open your work from older versions.

What's This?

A simple music editor with a focus on classical musical notation.

Follow the development at http://noisicaa.blogspot.com/

License: GPL2 (see file COPYING).

Requirements

This project is currenly only designed to run on Linux desktops. No effort has yet been made to make it run on anything else than Ubuntu 16.04 and 17.10 (which are the distributions used for development).

Getting Started

These instructions are not targetted at end users. There are not prebuilt binary packages, which you could just install, so you have to build from source. It is assumed that you're moderately experienced with software development on Linux.

First grab the latest source code:

git clone https://github.com/odahoda/noisicaa.git
cd noisicaa

Then install the deb packages that are needed to build and run it:

sudo apt-get install $(./listdeps --system --build)

For the first time setup, create a new virtualenv:

python3 -m venv ENV
. ENV/bin/activate
pip install --upgrade pip wheel

And populate it with a bunch of python packages that noisicaä uses:

pip install $(./listdeps --pip --build)

Now you should be ready to build it:

python3 setup.py build

There is currently no way to install it, so you can only run it from the build directory using

bin/noisicaä

Everytime you open a new bash to work with it, you have to activate the virtual environment using

. ENV/bin/activate